F.A.Q.

MyBoost / App FAQ

MyBoost / App FAQ

Show first post

37 replies

Userlevel 1

Hi there. Can anyone help me please. I've always topped up with my boost App but for the past 2 days as its going through for payment it's says this... 

I have contacted my bank and there no issue there... Boost helpline are confused too. I have deleted my app and reinstalled it, to no avail. 

Userlevel 4
Badge +1

Hey @Mazbabz,

 

I’ve moved your topic to this existing FAQ to make sure we keep all MyBoost issues are kept in one place. It also makes it easier for other users to find this information!

If you look at my topic above, I briefly cover possible reasons for top up issues.

 

Have you tried removing your debit card information from the app and then re-adding this information to see if it works?

 

Let us know how you get on,

Bradley 

Userlevel 1

Hi

Thanks so much for your reply.... I deleted my card again and reinstalled it. Works great now, yippee! 

Userlevel 4
Badge +1

Amazing news @Mazbabz!

 

Thanks for letting us know what happened! :relaxed:

 

Bradley

I used to have a rolling top up when boost was ovo, but when it switched over it stopped. Now I want to start a rolling top up again it says I need 1 manual top up (I have been topping up for years). I have tried logging out and back in but still nothing.

Any other ideas?? 

Userlevel 4
Badge +1

Hey @Clairehill4789,

 

I’ve moved your query here to help answer your question. It looks like there may be an issue here that needs further attention.

 

I’d recommend checking out Boosts contact information above in order to chase this.

 

Cheers,

I have just has a new smart meter installed but I am unable to log into my account via the app or website.. the pages dont load???

Userlevel 4
Badge +1

This may not be an unusual thing @Saralou1984,

 

It can take up to 2-3 working days until the app is up and running. You should be on a friendly non-disconnect period until the app is ready to go. 

 

Keep your eyes peeled for an email letting you know when it’s ready!

Cheers,

Have been topping up my smart PAYG+ by auto direct debit once the balance got down to an agreed level. Than in Dec.2019, for unknown reason, was advised by Boost that they were unable to collect the DD and would I pay manually.  Replied to Boost via email that nothing had changed my end, and my Bank had advised me that they had not been asked for any payment, so logically, the fault would appear to be with Boost. The replies I received from Boost did nothing to solve the problem, and I still continue to top up manually which is a pain, and flies in the face of why I signed up with OVO/Boost in the first place. My card details etc are as they have always been, and as detailed on my account entry, so what is the problem. Does anyone else suffer from this issue? I don’t intend to for much longer.

Userlevel 4
Badge +1

Hey @mitchdh,

 

I’ve moved your question here to make sure we keep all app related issues in one place. This makes it easier for other users also having the same issue to find.

 

It’s frustrating that the issue still hasn't been fixed, so I would recommend reaching out to the Boost team via the contact methods mentioned above.

 

Please let us know how you get on,

I have forgotten my email I first used to sign up to boost is there any chance i can find out what it is or change it 

Userlevel 4
Badge +1

Hey there @Julie1967 

 

I’ve moved your question here to get you the help you need.

 

Check out my topic above to get the answers you’re looking for. If you ever want to confirm any details about your Boost account, you can reach out to a Boost agent via the above contact info.

 

Hope that helps,

Reply